Manu Raghavan

Rvmsudo

If Apache’s www-data (or similar) user on your server keeps reverting to Ruby1.8 instead of respecting whatever setting you had with RVM, check the version of Passenger gem you have installed.

The passenger gem should be in

1
ls $rvm_path/gems

To confirm, check the shebang pre-processor directive on passenger-config If it says:

1
#!/usr/bin ruby1.8

… you’re doing it wrong! Uninstall that gem, and start over with:

1
2
$ sudo gem uninstall passenger
$ rvmsudo gem install passenger

Comments